彻底解决 Chrome,FireFox,Edge 的 “此 Flash Player 与您的地区不相容”问题

yain 的梦境 码字、听歌、周游世界 本文由博客端 http://localhost 主动推送
本贴最后更新于 186 天前,其中的信息可能已经沧海桑田

前言

最近在学习 selenium 进行网站的自动化测试,突发奇想可以使用 selenium 来制作一款 Flash 游戏的辅助程序。话不多说,开始研究,没想到却碰到了最头疼的问题。“此 Flash Player 与您的地区不相容,请重新安装 Flash”,我电脑上的三大浏览器,Chrome,Firefox 和 Edge 全部陷落。在网上找了很多解决办法,都没有完全解决,可能是因为时间的缘故吧。最终,在结合了前人的多篇博文后,成功解决了此问题,在此记录下来。截止至发稿日期,此方法博主亲测有效,但在过一段时间可能就不行了,毕竟 Flash 要被淘汰了,唉,可惜了我童年的 4399 小游戏

下载安装包

不要使用最新的 Flash,目前最新版本的 Flash 好像是 32.0.0.344,这个版本博主不管怎么尝试都是有问题的,不管是从官网上下载的,还是从第三方网站上下载的,都有问题!也是无奈了
这里给出 Adobe Flash Player 29.0.0.140 的百度网盘地址
Adobe Flash Player 29.0.0.140 密码:4l0l

QQ 截图 20200326011644.png

卸载之前的 Flash

运行 uninstall_flash_player.exe 即可

安装方法

找到然后下载对应自己浏览器的安装程序,在安装之前,一定要断网,一定要断网,一定要断网,重要的事情说三遍,不断网的话一运行安装程序就会打开最新版本的下载地址,贼流氓。
断网之后就可以正常安装了,记得在安装最后一个界面,选择“从不检查更新
在安装完成之后,打开 Chrome 或 Edge,可能会发现还是有问题,别慌,还有一个步骤我们要做,那就是把浏览器默认使用的 Flash 目录给禁用掉,这里可以参考这篇博文,里面描述的比较详细,我就不再赘述了。
最后修改完成之后,你的 里的 flash 路径应该是类似这样子的
QQ 截图 20200326013126.png

Chrome 和最新版的 Edge 都可以用禁用原来 Flash 的目录来解决。
Firefox 只需要在插件中将刚刚安装的 29 版本的 Flash 启用即可,如下图
QQ 截图 20200326013346.png

写在最后

引用其他博文中的一句话:落后就要挨打,该消失就该消失,该研究新技术就研究新技术,而不是做出这种不要脸到极点的事情来赚钱,再伟大的东西都会因为一个污点而遗臭万年。

  • Chrome

    Chrome 又称 Google 浏览器,是一个由谷歌公司开发的网页浏览器。该浏览器是基于其他开源软件所编写,包括 WebKit,目标是提升稳定性、速度和安全性,并创造出简单且有效率的使用者界面。

    51 引用 • 275 回帖 • 517 关注
  • Firefox

    Mozilla Firefox 中文俗称“火狐”(正式缩写为 Fx 或 fx,非正式缩写为 FF),是一个开源的网页浏览器,使用 Gecko 排版引擎,支持多种操作系统,如 Windows、OSX 及 Linux 等。

    7 引用 • 30 回帖 • 550 关注
  • Edge
    3 引用 • 20 回帖
  • Flash
    2 引用 • 13 回帖

赞助商 我要投放

欢迎来到这里!

我们正在构建一个小众社区,大家在这里相互信任,以平等 • 自由 • 奔放的价值观进行分享交流。最终,希望大家能够找到与自己志同道合的伙伴,共同成长。

注册 关于
请输入回帖内容 ...
  • someone9891
    捐赠者

    没意思了,马上 Ghrome 就不支持了

    1 回复
  • ylsislove
    捐赠者 作者

    挺可惜的,很怀念以前玩的 4399flash 小游戏