Sym 在 linux 环境上前端安装编译不过

我下载 symphony 3.6.3 版本分支,后端倒是很容易编译打包成功了,但前端安装时,卡在 node-sass 上,怎么也过不去,总是安装失败,问一下,前端 的 npm node 又什么版本限制吗?

我的安装环境是:

archlinux linux kell 5.12.1

node: 16.1.0

npm :7.11.2

cnpm: 6.2.0

社区源码 symphony 3.6.3

  • Sym

    Sym 是一款用 Java 实现的现代化社区(论坛/BBS/社交网络/博客)系统平台,“下一代的社区系统,为未来而构建”。

    502 引用 • 4505 回帖 • 653 关注
  • Q&A

    提问之前请先看《提问的智慧》,好的问题比好的答案更有价值。

    2261 引用 • 13239 回帖 • 544 关注

广告 我要投放

欢迎来到这里!

我们正在构建一个小众社区,大家在这里相互信任,以平等 • 自由 • 奔放的价值观进行分享交流。最终,希望大家能够找到与自己志同道合的伙伴,共同成长。

注册 关于
请输入回帖内容 ...
  • pemolin 1 赞同
    作者

    我可能没说明白,过了两周,再补充一下,开源项目的源码,如果按照安装部署手册,用 nodejs 编译前端,会总是提示失败。

  • liyong02

    用不着 vue 编译,前端用的 freemarker,可以直接运行。